“What version of Minecraft is this mod version for?”

UPDATE: My mods now come with the MC version they’re intended for in the file name before the version number from 1.10.2 onwards. Just look for the bunch of numbers after the name but before the dash (-).

 

Hey guys,

I’ve been seeing a few posts asking what mod version is for what version of Minecraft, so I’d just like to point out this old post of mine from a while back that explains how my version numbering works.

Anyhow, let’s get to it:

  • The version number starts with a number equal to or larger than 2. This is the start of the new versioning system I’m currently using. Mods with this versioning system will require iChunUtil.
    • 2.X.X is for Minecraft 1.6.2/4
    • 3.X.X is for Minecraft 1.7.2
    • 4.X.X is for Minecraft 1.7.10
    • 5.X.X is for Minecraft 1.8.0
    • 6.X.X is for Minecraft 1.10.2 (1.8.9, 1.9.0 and 1.9.4 do not exist because I have no mods on those that use this system)
  • The version number is <Minecraft Version>-1.X.X. These mods have the MC version labelled next to the download and does not require iChunUtil.
  • The version number starts with 0.X.X. These mods would normally have the MC version labelled next to the download, since it deviates from my norm. The only mods fitting this category are Morph and any ModJam-build versions of mods.
  • The version number is 1.X.XvY. The “1.X.X” denotes the Minecraft version while the “vY” part denotes the build for that version of Minecraft. Basically, <Minecraft>v<Build>. If the version is just 1.0.X, it is for Minecraft 1.5.X.

I’ll probably update this list in the future and link back here so that people don’t get confused and stuff. If you stumbled upon here looking for a version number that’s after the listed versions, try to go logically in order of major Minecraft releases and you should have your answer.

Some mods may have a “Deobf” download. If you’re not a modder, you probably won’t need this.

 

 

Oh. I probably should add that PortalGun and Gravity Gun are skipping 1.7 entirely. Because reasons. Some of it being life (I’ve moved to Ireland!), some of it being code-related. So please, just stop asking for it. I’ll try my best to bring it back in 1.8, GraviGun first then PortalGun after.

Cheers,
iChun

40 Comments

  1. Tahg October 8, 2014 8:09 am  Reply

    perhaps you could update your “Why are your mod version numbers so weird?” FAQ to this post

    • UGHHHH March 13, 2015 11:20 pm  Reply

      When i put this in my mods folder and load minecraft it says that your mod cannot be found because 4.0.0 is minimum and All you have is STUPID 0.9.1 . IT IS NOT WORKING. A LITTLE HELP

      • Hi! And HELP May 4, 2015 5:54 am  Reply

        IKR! i can’t play and its bumming me out so much ! Q.Q!

      • bob January 4, 2016 1:04 pm  Reply

        ikr please help!!!!!!!

      • helppp :O January 21, 2016 10:21 am  Reply

        omg this is making me sad 🙁 im not able to play it because of the same thing i really want to play this mod 🙁

      • Aqua August 31, 2016 2:29 am  Reply

        U need iChunUtil it did that 2 me i put iChun util in my mods it worked 🙂

  2. Versus_MC October 9, 2014 9:24 pm  Reply

    I’m disappointed to hear that PortalGun and GravityGun won’t be updated for 1.7; I’ve been coming here daily to check for an the updated versions. Hopefully they’ll be back in 1.8, keep doing what you do best iChun!

  3. lukester October 15, 2014 11:30 pm  Reply

    same

  4. lukester October 15, 2014 11:30 pm  Reply

    =(

  5. Kaylee_Chanel October 17, 2014 4:00 am  Reply

    I came here looking for an update for PortalGun for 1.7.10 as well, but I’m actually glad there’s news about it just skipping rather than -no news- or even just having the mod die off. Thanks for your hard work, and I’m sure I’ll survive without it for 1.7.

    Do what you need, settle in with your new home, and we’ll all be here for PortalGun and GravityGun in 1.8.

  6. JokerGregor October 19, 2014 8:39 pm  Reply

    I beg of you, please update also Mob Amputation for 1.8. I will donate some money as well but please. I enjoyed this mod just unbelievable much

    • AnonymousMan2015 February 1, 2015 1:03 pm  Reply

      GO AWAY LIVING SPAMBOT!!! >: (

    • Mrnoname1000 February 4, 2015 3:18 pm  Reply

      If you’re going to try to get a free minecraft account, at least spam a website where you can remove the message.

    • pcpcpc12 August 16, 2015 3:28 pm  Reply

      THAT MUST BE ILLEGAL!!!

  7. bnl1 November 4, 2014 6:30 am  Reply

    Please, add a laser(grill,checkpoint,etc…) to the portal gun

  8. Ordan November 14, 2014 1:14 am  Reply

    when do you plan on making the Anti-chamber mod?

    • Timdeuces March 25, 2015 6:53 am  Reply

      How would that work? It’s got many context-sensitive mechanics.

  9. AnonymousMan2015 February 1, 2015 1:04 pm  Reply

    Wait, I’m trying to install portal gun and iChunUtil 2.4.0 (I think, I don’t have my mods list in front of me) crashes the game. I’ll try downloading an older version, but I just thought you might want to know.

  10. yo man February 15, 2015 6:22 am  Reply

    and its really hard to just add (MC – 1.6.4) beside the vesion numbers on the download page?

    • Gustavo6046 February 25, 2015 7:39 am  Reply

      Maybe he can’t, because deobf doesn’t lets him to. Also, yo man, I want to clarify that his version number system is good as it is, if you can’t live with it, then cheers and fuck off. He is now working hard in something even bigger than the Pigzilla that felt from the sky, and so does me, in avaiabling GravGun and PortalGun for 1.7.10.

  11. Jazz February 17, 2015 1:15 pm  Reply

    So…the morph mod says it should be put into 1.7.10 and that’s what I’m doing..but it keeps displaying an error after the game launches but before the title screen shows. Plzz help. 🙁

  12. Gustavo6046 February 25, 2015 7:37 am  Reply

    Cheers, iChun.
    I want to point you out some things.
    First, Ireland = fuck. Way too much noise, lack of nature, conflicts with the Britanic Ireland etc. I travelled there one single day one day and I’m glad I didn’t stayed for much more. Here back in Brazil = shit too, but not as conflicting. Only intellectually ridiculous politics. However St. Georgia is a big marvel, and that I can tell from photos done by Google sattelites!

    • pcpcpc12 July 14, 2015 11:34 pm  Reply

      I wish you luck…

  13. LatinoGringo February 28, 2015 6:56 pm  Reply

    So I’m just getting into mods for minecraft and i want to install this mod but im still slow on your number system. I’m using feed the beast mod packs, specifically feed the beast unleashed. its version 1.5.2. which one should i download specifically for this? unless you dont have that version anymore

  14. Pr0kKiLlEr March 2, 2015 11:03 pm  Reply

    hi,
    you said that versions 4.0.0 are for 1.7.10.well i tried to play 2 mods which are versions 4.0.0 and you said these are for 1.7.10.well i tried to play them and it said they are minecraft versions 4.0.0 what should i do?

  15. Aidan (Nunya) March 20, 2015 2:27 pm  Reply

    Yo im so glad ichun responds to our pleads oh wait he doesnt and nice job on screwing up the tabula with the “you need 4.1.3” glitch smooth move idiot

  16. furiouspixelz March 23, 2015 1:38 am  Reply

    which is the download version for minecraft 1.7.10

  17. shadowclank March 26, 2015 4:05 am  Reply

    1.7.5?

  18. pcpcpc12 July 14, 2015 11:32 pm  Reply

    Ichun thank you so much for adding the answer to
    my question. Now i know why portal gun is not for 1.8 yet.

  19. Jack July 23, 2015 1:26 am  Reply

    Ichun, I want 1.6.4 gravity gun but when I get the 2.0.0 and when I open Minecraft it says that the minimum version for that mod is 2.0.0 I NEED HELP

  20. HelperBot February 25, 2016 8:14 am  Reply

    here is a link for 1.7.10 p.s just press “start download”

Leave a comment

Your email address will not be published. Required fields are marked *