An update on MC 1.8.

Hey guys,

This is just a quick update post on what’s been happening lately in regards to my mods and such.

Right now I will have to admit that I am not in active development status, I’ve not been doing any dev work for quite a while with regards to life being busy with stuff and such. I do have some news however, once I get back into it, here’s what you can expect (before you ask, everything stated here are for 1.8 unless stated otherwise):

  • An update to iChunUtil
  • The release of BlockSteps (a new mod!)
  • The release of Bee Barker (also a new mod!)

After that, I’ll continue work on Morph for 1.8, which is getting a revamp in terms of both Abilities and a lot of internal reworks. Things *will* be changing for Morph in that version, and I’ll look for your feedback as usual as things develop. If I get bored of Morph, I will be working on the other mods I’ve not ported to 1.8 yet.

Word on Portal Gun though, that will have to wait a bit as a couple of things are waiting on something else that is beyond my control. Hats is waiting on Tabula and a couple of things that Tabula needs being worked on for the time being, with some things also being out of my control.

 

The problem:

Demand for mods in MC 1.8 just isn’t great. There aren’t that many people on 1.8 yet and a lot of other mods have not been updated. As most of my mods aren’t normally main mods, there isn’t a high demand for my mods to be updated to 1.8. The few that already are, are still getting more downloads for their 1.7.10 counterpart. Because of this, I’ve actually resorted to putting porting mods to 1.8 low on my priority list as I handle things going on IRL for the time being.

 

The silver lining:

I’m still keen on updating my mods to 1.8. Same goes for MC 1.8.8 whenever Forge is released for it. I see no reason to keep things on 1.7.10 when there is a newer modable version of MC available. I have things planned in terms of optimization of a couple of mods as well as gameplay changes, of which I’ll definitely have to get feedback from you folks in the future.

 

The twist:

As with how I’ve been doing with all my mods for the past few years or so, I only support the latest versions of mods, therefore if the mod has a 1.8 version available and there is an issue on the 1.7.10 version but not on the 1.8 version, *do not* expect it to be fixed. Another thing is, I have completely dropped major support for the following mods: Morph, Sync, Hats, Portal Gun. There are reasons for this, but I will not go into detail.

 

That’s it for now folks, sorry for long post, and not sorry for no tl;dr, I just felt like typing something and I figured an update would be nice.

 

Cheers,
iChun.

12 Comments

  1. Wasdennnoch September 22, 2015 12:32 pm  Reply

    Bee Barker aka the dog fisting mod 😀

    • X September 24, 2015 4:32 am  Reply

      XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
      Fuck You

  2. Konami Kode September 23, 2015 10:21 am  Reply

    When I got to “The Twist”, I thought you were saying you were DISCONTINUING those mods, and I was freaking out! Good thing I read it wrong!

    Anyways, keep up with the good work! I am excited to see your new mods.

    -Konami Kode

    • X September 24, 2015 4:32 am  Reply

      XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
      Fuck You

  3. X September 24, 2015 4:31 am  Reply

    XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    ICHUN Fuck You

  4. LeoTheBrony September 24, 2015 3:27 pm  Reply

    where are the new mods????

    • X September 25, 2015 2:36 am  Reply

      XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
      Fuck You

  5. GameOverGamingYT September 25, 2015 10:44 am  Reply

    Shame theres no support for portal-gun mod. I love that mod, i was looking forward to M.E.G.’ and T.D.B.’s.

  6. Mad Dreamer October 2, 2015 2:14 am  Reply

    An update to Keygrip mod is required too. The mod needs more options and bug fixes such as:

    -Riding horses and other mobs
    -Sitting animation
    -Step sounds while playing the recorded scene
    -Interacting with buttons, pressure plates, doors etc.
    -Custom skins from skindex or nova skin (by using URL)
    -Placing blocks

    Its so hard to make great machinimas without these features. Hope you read this and think about it^^

  7. Do_nut October 5, 2015 2:59 am  Reply

    i download pretty much *every* single mod and notice there are almost no 1.8 updated mods

    also wtf is x doing to the comments

    • X October 20, 2015 6:11 am  Reply

      XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
      The World May Never Know 🙂

  8. Sofia Engvall January 14, 2016 6:06 pm  Reply

    Hi ichun and thanks for all your great mods!!

    You talk about lots of people still using 1.7.10 most of the time and that’s true for us too… Though the reason is that mods don’t get updated to 1.8 due to people still using 1.7.10. How will people ever move on to 1.8 if the coolest mods are not available there? 😉

    My 8-year old son with autism would love to test the titan mobs mod out, only that it’s only for 1.8 so far and the thing he really loves is to use your morph mod to transform into the different monsters.

    As long as your morph mod isn’t available for 1.8 I don’t think we’ll ever play it.

    Your morph mod together with tomanyitems, an damageindicators mod and map mod (voxelmap) is the base package that makes minecraft minecraft for us 🙂

    We’d really really love if you had the opportunity to update the mod for 1.8.

    Thanks a million!!! <3

    /Sofia and Laban in Sweden

Leave a comment

Your email address will not be published. Required fields are marked *